MyJEEPforum.com



 
HomeHome  PortalPortal  CalendarCalendar  GalleryGallery  FAQFAQ  RegisterRegister  Log inLog in  

Share | 
 

 Hey Geo or anybody...

View previous topic View next topic Go down 
AuthorMessage
landshark
Straight off the lot
Straight off the lot
avatar

Number of posts : 42
Age : 57
Location : Katy
Rig : 07 Rubicon
specs. : bunch-o-stuff
Registration date : 2008-10-28

PostSubject: Hey Geo or anybody...   Mon 30 Mar 2009, 12:10 pm

Broke the sway bar end link on the driver side down at the bottom pin (disco's) that came with my Skyjacker 4" lift. sorry no pics...anyway, just an opportunity to get new ones, ORE End Links....freakin awesome. I have a question, does anyone know why the SJ end links would have broken? I have a Rubicon and was disconnected at the time, I never heard anything break which is odd because that is a pretty tough part to break I would think. Also, my sway bar disconnect light keeps flashing. When I installed the ORE end links I was able to move the drivers side end fairly freely (this would indicate sway bar disconnected) however the passenger side wouldn't even budge (would indicate connected) so I guess my question would be, does anyone know what could be wrong or do I need to take it to the dealer?
Back to top Go down
View user profile
terrahawk
Got No Life
Got No Life
avatar

Number of posts : 1593
Age : 48
Location : Richmond, TX
Rig : 2007 Sahara dos puertas
Registration date : 2008-03-30

PostSubject: Re: Hey Geo or anybody...   Mon 30 Mar 2009, 12:18 pm

I would scrap that whole thing bud and just put a regular cave man swaybar on there. JMHO though. Cool
Back to top Go down
View user profile
07_Rubi
Trail Ready
Trail Ready
avatar

Number of posts : 63
Location : Waller
Rig : 07 Rubi
specs. : a few
Registration date : 2009-03-04

PostSubject: Re: Hey Geo or anybody...   Mon 30 Mar 2009, 11:49 pm

Repllace the links with some ORE or Currie Links and I'm sure the blinking sway bar light will go away. I disagree with you Terrahawk - it's nice beeing able to push button disconnect and reconnect for different situations where you don't want as much flex...but everybody has his own preferences... Smile
Back to top Go down
View user profile
redneckhouston
#1 asshole
avatar

Number of posts : 1161
Location : hempstead, tx
Rig : 08 jk unlimited
specs. : 26" spinners, curb feelers, and 6 15 in woofers
Registration date : 2008-02-07

PostSubject: Re: Hey Geo or anybody...   Tue 31 Mar 2009, 12:26 am

dave, i believe you over-extended the sway bar ........basically either on the droop end or the compresion end of things the suspension moved alot further than the sway bar disconect motor would let it.........i suspect the sway bar collar and maybe the motor itself are damaged

i doubt the dealer will warrienty it............

i would look into it and if they wont fix it, a antirock from currie would be the best option.........and a aev procal to turn off the blinking light

_________________
ITS HIP TO BE SQUARE

[embed-flash(width,height)]
Back to top Go down
View user profile http://WWW.ROCKRASH4X4.COM
Sponsored content




PostSubject: Re: Hey Geo or anybody...   

Back to top Go down
 
Hey Geo or anybody...
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
MyJEEPforum.com :: JEEP TECH :: Modified Tech-
Jump to: